November 10, 2018 admin

VR Easy v1.51

We are submitting 1.51 soon please read carefully before updating the package once ready:

1) VREasy 1.51 no longer supports Unity 5.6 and it only compatible with Unity 2017.x and above.

2) Users that wish to use SteamVR 2 and VREasy must update to the current version 1.51

3) Users that want to keep using SteamVR 1.x integration with VREasy must remain in VREasy version 1.5.

4) Because SteamVR 2.0 is a wrapper of OpenVR, and Unity VR native input (https://docs.unity3d.com/Manual/OpenVRControllers.html) controller uses also its own version of OpenVR, one cannot use both at the same time. Our GenericControllerTrigger is built on top of Unity VR native input control, hence it won’t work if the project uses SteamVR 2.0. If SteamVR 2.0 functionality is required, our users are recommended to use SteamControllerGrab triggers instead of GenericControllerTriggers (as they offer the same functionality).
We have plans to extend the use of SteamVR 2 in VREasy 1.6, but that will take some time, so we thought releasing this version was important to at least allow our suers to use VReasy with the new SteamVR plugin.
We have also recorder video tutorials of how to set up a controller trigger and Simple FPS locomotion with the new SteamVR 2.
Please contact us if you have any issues or questions so we can help you out.
Thank you

Leave a Reply

Your email address will not be published. Required fields are marked *